Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-08-2009, 03:04 PM
Registered User
 
Join Date: Oct 2009
Location: Salinas, Ca
Posts: 20
Instrument cluster will not come out W123

I have a '78 280E. I want to do some work on the cluster. In reading some of the steps to remove the cluster, the simplest looked to be remove panel and push from behind....very easy right? I am pushing, pulling, everything possible and it doesn't come out it comes out partial and then...no more. It's like something in the middle is keeping it in but I can see nothing that should do this. Any helpful solutions?

Reply With Quote
  #2  
Old 10-08-2009, 03:32 PM
Registered User
 
Join Date: Jan 2006
Location: Tucson, AZ
Posts: 4,771
Disconnect the speedo cable.
Reply With Quote
  #3  
Old 10-08-2009, 05:50 PM
Member
 
Join Date: Jan 2003
Location: Florida
Posts: 1,084
From my 123 days, remove the speedo cable from the trans, also be carefull of the oil line going to the cluster
Reply With Quote
  #4  
Old 10-08-2009, 06:07 PM
Yak Yak is offline
Registered User
 
Join Date: Aug 2009
Location: San Antonio, TX
Posts: 1,711
Look in the engine bay for a plastic clip that holds the speedo cable in place. Follow the the cable out from the firewall grommet to help locate the clip. Disconnect the clip. This will provide a little more slack so you can unscrew the cable from the cluster.

The cluster may be hung up on sagging/fallen insulation from the underside of the dash. There are a few wires or bundles that are on it that may hang up.

Good pic here of the cluster being removed. www.peachparts.com/Wikka/W123Evaporator

You can check the w124 cluster removal link as well.
Reply With Quote
  #5  
Old 10-08-2009, 06:07 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,131
reach your hand up behind the dash and disconnect the speedo cable.

__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page