Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-14-2001, 01:07 PM
Registered User
Join Date: Nov 2001
Location: Miami, FL
Posts: 70
Exclamation Help! More transmission "CLUNKing"

Well, after taking my C280 to my Independent, the vibration felt when putting the car in gear turned out to be the motor mounts. The mechanic says the transmission might be hosed - there is a solid "CLUNK" when putting it in gear (not normal for sure - it's very hard). My question is: I've only got 43K on the car - I've heard and seen on here a lot of concerns about the transmission on these cars, so what other things should I be thinking about? I've read on hear about these machines needing a new tranny computer - a recall by MB or something. Please tell me there are other things to look at besides a rebuilt transmission - my mechanic is awesome, but this seems a bit extreme. HELP! and thanks!

Mark E.
Mark E.
Miami, FL
2 X 1997 C280
Reply With Quote
Old 11-14-2001, 05:53 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like you have a 1997 or later C280? ASSuming that is the case then get back to your local dealer & complain about this problem! They might(should) get you some GOODWILL help on this problem.

One of the biggest problems with this trans IS MB says that they have LIFETIME fluid fill. And if you want the lifetime to be less than 100K miles you WILL believe that. Otherwise have the trans serviced!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 11-14-2001, 07:01 PM
Registered User
Join Date: Nov 2001
Location: Miami, FL
Posts: 70
Thanks Sir! Yes, it is a '97. The trans does some wierd stuff - one day it works fine, the next it downshifts hard. I was told by a MB tech that a software update and/or checking out the speed (shift?) sensor plate should do the trick. I just don't know what to ask for when I take it in. Thanks for your reply!

Mark E.
Mark E.
Miami, FL
2 X 1997 C280
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto -> Manual Transmission Conversion Has Begun. R Leo Diesel Discussion 341 08-15-2016 07:21 AM
1999 S500 with 722.6 Automatic Transmission Filled for life? MBD Tech Help 29 07-30-2011 11:51 AM
transmission slip reverse 722.4 bgarvey Tech Help 2 02-23-2005 12:39 AM
99 S320 Transmission noise BENZ TEK Tech Help 0 06-10-2003 10:32 PM
M116 removal from 82 380SL rstarkie Tech Help 3 11-14-2002 07:03 AM

All times are GMT -4. The time now is 11:32 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page