Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2009, 10:57 AM
Super Member
 
Join Date: Aug 2001
Location: Kansas City Missouri
Posts: 111
Help! Car stalling out.

Hey guys, this problem has been happening for awhile now, probably 6 months atleast. The problem is that if I am creeping real slow or am sitting still with the car in drive, like at a light, it will die. When it dies it pops up my ASR CEL and then the charge battery CEL. This has been happening with more frequency as of late and it is really beginning to bother me.
Watching the tach it looks like it is idleing at about 600 rpm, and every 10 seconds or so it looks like it dips slightly like an accessory is coming on. It is kind of random and doesnt happen everyday but it is embarrassing.

Has anyone else had a similar problem. I need to get this fixed but Im not sure where to start. Thanks for your help.

__________________
1997 E420 Black Opal

"Why do I have to be Mr Pink"?
Reply With Quote
  #2  
Old 11-11-2009, 11:29 AM
Registered User
 
Join Date: Sep 2009
Location: Great State of Texas
Posts: 440
Quote:
Originally Posted by craiggotgame View Post
Hey guys, this problem has been happening for awhile now, probably 6 months atleast. The problem is that if I am creeping real slow or am sitting still with the car in drive, like at a light, it will die. When it dies it pops up my ASR CEL and then the charge battery CEL. This has been happening with more frequency as of late and it is really beginning to bother me.
Watching the tach it looks like it is idleing at about 600 rpm, and every 10 seconds or so it looks like it dips slightly like an accessory is coming on. It is kind of random and doesnt happen everyday but it is embarrassing.

Has anyone else had a similar problem. I need to get this fixed but Im not sure where to start. Thanks for your help.
If your key is on but your engine not running, all of your emergency lights should be lit - that's normal.

How well does it drive when not "creeping"? How many miles are on it and when's the last time it got tune-up parts?
__________________
A.S.E Tech A1,A6,A7,A8 & MVAC 609 + EPA 608

Unless stated otherwise, any question I ask is about my greymarket 1985 380SEL.
Reply With Quote
  #3  
Old 11-11-2009, 11:47 PM
Super Member
 
Join Date: Aug 2001
Location: Kansas City Missouri
Posts: 111
When it dies it pops up on the message display "asr traction control" and then "charge battery" messages. Its not the little lights. Air filter and spark plugs are good. I changed them this summer. 211K on the clock and I dont think I have changed the Mass air flow sensor in the 9 years Ive had the car. I have been told that could be the culprit. But for $250 I wanted to get your guys opinion on it. I was also told that bad motor mounts can cause this too.??
__________________
1997 E420 Black Opal

"Why do I have to be Mr Pink"?
Reply With Quote
  #4  
Old 11-12-2009, 02:33 PM
Registered User
 
Join Date: Sep 2009
Location: Great State of Texas
Posts: 440
I'm not familiar with your engine/model, but If your MAF is a true MAF (hotwire), just tapping on it with the engine running should cause the engine to act up. Try disconnecting it and then starting the car; the ECM should block out that input and use the rest of the sensors to run the engine.
__________________
A.S.E Tech A1,A6,A7,A8 & MVAC 609 + EPA 608

Unless stated otherwise, any question I ask is about my greymarket 1985 380SEL.
Reply With Quote
  #5  
Old 11-13-2009, 10:50 AM
Super Member
 
Join Date: Aug 2001
Location: Kansas City Missouri
Posts: 111
Ok Ill try that. It died twice last night while I was sitting in line getting my wife some Arby's. It's really beginning to bother me.
__________________
1997 E420 Black Opal

"Why do I have to be Mr Pink"?
Reply With Quote
  #6  
Old 11-14-2009, 12:04 AM
Super Member
 
Join Date: Aug 2001
Location: Kansas City Missouri
Posts: 111
Anything else you guys think I should try?

__________________
1997 E420 Black Opal

"Why do I have to be Mr Pink"?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page