Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2009, 01:17 PM
dproudfo's Avatar
Registered User
 
Join Date: Jul 2006
Location: Saint Paul, Minnesota
Posts: 139
W124 E420 Heater Control Valve

Car is a 1995 E420 and I've been having to hunt down a popping/ticking sound from inside my dash for the past few months and have finally found the culprit. The heater control valve on the passenger side. When it's active, it ticks/pulses every 4-5 seconds constantly as long as the heat is on in the car. This noise is transferred to the cabin and is very audible. Anyone have any insight into what the problem could be. I always thought the ticking of the valve was normal operation. My guesses are that the valve is simply louder than it should be (replace) or that its operating too often (either the valve itself or the CCU). Any feedback would be great! Thanks!

__________________
1995 E420
1998 SL500 Sport
2009 E350 Sport
1995 S500 Coupe
1992 500 SEL
Reply With Quote
  #2  
Old 12-05-2009, 01:35 PM
dproudfo's Avatar
Registered User
 
Join Date: Jul 2006
Location: Saint Paul, Minnesota
Posts: 139
Update...

I just wanted to post an update to see if anyone can shed a little light on the problem. The 'clicking' occurs as soon as the car is up to cabin temperature. It is always at regular 4-5 second intervals. If I have the thermostat at a moderate cabin temperature it will continue to click non-stop once at temperature. If I crank the heat up the clicking will stop for a while until the car gets back up to the higher requested temp. I'm assuming this is the valve's normal response for the increase in demand for more heat. The the more heat the heater core demands, the more the valve lets through. This is pointing me to believe that the valve is just louder than it should be (why I have no idea). Keep me posted!
__________________
1995 E420
1998 SL500 Sport
2009 E350 Sport
1995 S500 Coupe
1992 500 SEL
Reply With Quote
  #3  
Old 12-05-2009, 07:04 PM
Registered User
 
Join Date: Jan 2008
Location: Melbourne Australia
Posts: 844
The duovalve on my 89 260e clicks every 4 - 5 seconds. I don't know if you have the same setup in your car.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page