Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2001, 04:19 PM
renok7's Avatar
Registered User
 
Join Date: Nov 2001
Location: Montréal
Posts: 95
Question High Fan Speed Won't Work

I own a '93 300E 4 matic. With the ignition key on instruments the high fan setting works normally. However, when the car is running, the high fan setting won't work. My mechanic thinks that the blower motor regulator switch is defective but he isn't sure since the high fan setting works normally when the car in not running (i.e. instruments only). Before that he had replaced the ignition switch and tried a new push button control but to no avail. Any input would be greatly appreciated.

Thanks
__________________
Reno

'93 300E 4Matic
'98 Nissan Altima
'00 Yamaha Road Star Silverado

Last edited by renok7; 11-17-2001 at 06:12 PM.
Reply With Quote
  #2  
Old 11-18-2001, 12:28 AM
Senior Member
 
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
Check the alternator output. An overcharging alternator will affect the blower motor.
Reply With Quote
  #3  
Old 11-18-2001, 12:35 AM
renok7's Avatar
Registered User
 
Join Date: Nov 2001
Location: Montréal
Posts: 95
Thanks Stan for the feedback.

The alternator was checked and isn't overcharging.
__________________
Reno

'93 300E 4Matic
'98 Nissan Altima
'00 Yamaha Road Star Silverado
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tire Tech Luke@tirerack Wheels & Tires 3 12-13-2006 04:32 PM
Viscous coupled fan for M102 possibility? Greg in Oz Tech Help 0 05-26-2003 05:09 AM
81-300TD - Fan blows HIGH ALL THE TIME!! gsamuelson Diesel Discussion 1 11-18-2002 03:57 PM
High speed driving and proper tire pressure. Jim H Wheels & Tires 1 11-07-2000 01:41 PM



All times are GMT -4. The time now is 03:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page