Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-29-2001, 04:21 PM
Registered User
Join Date: Sep 2001
Location: Austin
Posts: 28
95 S500 Transmission Problems

I've got a 95 S500 Sedan that shifts fine. Problem is, the car has begun to take several seconds to get into gear (from park) and even longer into reverse. The problem is much worse when the car is cold. Any ideas?
Reply With Quote
Old 11-30-2001, 05:13 AM
Registered User
Join Date: Dec 2000
Posts: 368
When was the last time you had a fluid filter service?
If it's been a while, you should get one ASAP.

Reply With Quote
Old 11-30-2001, 10:18 AM
Registered User
Join Date: Sep 2001
Location: Austin
Posts: 28
About 6000k ago. The fluid appears to be clean.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Problems CDNC36AMG Tech Help 3 10-14-2004 04:39 PM
Transmission Problems Bob123 Diesel Discussion 5 03-21-2003 07:58 PM
Transmission problems? '64 220S MB1964-220S Vintage Mercedes 5 06-13-2002 08:47 PM
Transmission problems for '64 MB1964-220S Tech Help 0 06-11-2002 12:31 AM
1980 300D Transmission Problems EK300D Diesel Discussion 0 08-10-2001 12:14 AM

All times are GMT -4. The time now is 07:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page