Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-05-2001, 04:22 PM
Posts: n/a
Engine cutting out- 90 300E

Hope someone can help me with this. Today all of the sudden when waiting in a drive thru, my engine cut out on me. When i tried to restart, it took a while, then would only stay on a few minutes. Then i let it sit for an hour, and all ran fine.. anyone know what might be causing this? Everything else seemed fine, temperature fine, no leaks coming from the engine..
Reply With Quote
Old 12-05-2001, 04:36 PM
Registered User
Join Date: Jun 2000
Location: Tucson, Arizona, USA
Posts: 180
I would guess a bad fuel pump relay -- check the archives. Hope others agree. . . Cheers, Andrew Seidel.


I am having a peculiar stalling problem with my 1988 300E?
86 560SEC
85 500SEC Lorinser
83 300D Turbo
75 240D
Reply With Quote
Old 12-06-2001, 12:24 AM
Senior Member
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
I have seen in rare occasions the ignition coil bad. Usually the only problem they present is difficult starting.
Reply With Quote
Old 12-06-2001, 08:58 AM
Registered User
Join Date: Apr 2001
Location: Indianapolis
Posts: 87
I had the very same problem with my '88 300E about two months ago. After several tests, it turned out to be the fuel pump relay. The relay controls other items aside from the fuel pump. It is relatively simple to change and it ended up costing me $229 with labor and diagnostics.
'88 300E
'00 Expedition
'86 Alfa Romeo Spider
'84 Harley Davidson FLH"X"
Special Edition
'70 FJ40 Land Cruiser (basket case)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300E / 3.OL - Engine Wiring Harness Pelo 300E Tech Help 3 01-09-2005 04:24 PM
Alternate engine 300E newEngine Tech Help 2 09-24-2004 10:17 AM
'91 300E 3.0 check engine light, code 17, after 02 sensor replacement kristian85 Tech Help 1 07-16-2004 11:40 AM
FS: NEW Engine Cover for 300E, 300CE, 300TE Benzwood Mercedes Used Parts For Sale & Wanted 8 09-04-2003 06:31 PM
88 MB 300E is cutting off while driving hpapad01 Tech Help 9 12-03-2001 02:17 PM

All times are GMT -4. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page