Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-07-2001, 11:50 AM
Posts: n/a
420 SEL - Maddening Check Eng Light problem

I've posted a bit on this before, trouble with a repair shop that did engine work on my car and ever since a rough idle and check engine light. But, now I have more info...

The trouble code keeps coming up as 09 E.H.A. out of range due to engine temp or voltage input.

The shop working on the car replaced the coolant temp sensor, thermostat, CIS Air Temp Sensor, Overload Relay, Alternator......all to no avail, the light keeps coming back.

They tell me it can't be related to their valve repair work, but I'm skeptical since that is when it started. Had the car in to this place 8 TIMES!!

So...I'm hoping someone out there might have some ideas on where else to look. This problem has been nightmare and I'm going to take the car to another shop, but don't want to continue to throw parts at it in hopes it cures the problem.

Could a sticking valve indirectly trigger a check engine light? What other things to check?
Reply With Quote
Old 12-08-2001, 05:18 AM
dpetryk's Avatar
Electrons can do anything
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
Your mixture might be off. If the mechanical mixture setting (same as the CO adjustment) is off, the Lambda controller cannot bring it back to normal and the light comes on. Check the on-off ratio at the diagnostic socket to see if you are out of adjustment.
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 500SL ASR Problem jrodnar SL Forum 10 12-22-2008 11:18 AM
Throwing codes W/O the check eng light on. Nektopoli Tech Help 1 07-19-2004 08:01 AM
'91 300E 3.0 check engine light, code 17, after 02 sensor replacement kristian85 Tech Help 1 07-16-2004 11:40 AM
W126 420 SEL Dome light diagnosis help... 96C220 Tech Help 14 11-07-2002 01:11 AM
420 SEL orange panel light coming on, why? stanmick63 Tech Help 2 09-06-2001 01:35 PM

All times are GMT -4. The time now is 07:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page