Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-13-2010, 10:10 AM
Registered User
 
Join Date: Aug 2006
Location: Houston, TX
Posts: 450
Reluctant AC '92 300SE

Freon level is to spec.

A few DTC's - all in the intermittent category:
ECT sensor - open short (041)
In Car Temp Senaor - open/short (019)
Coolant Pump - open/short (075)
The open/short for coolant circulation pump has been here and gone since I got it 5 years ago, even after replacing the pump and having the HVAC control rebuilt. I finally decided to bite the bullet and replace the HVAC wiring harness. While I was at the parts counter at my local dealer, the 140 guru tech from the service department came in. He asked why I was ordering that harness and I told him. He said "save your money - I've never seen one actually fail, and that trouble code shows up in 95% of the 140's I work on. As long as the pump is working, ignore the message..."

So - the problem:
On occasion, you can start the car and the A/C blows cold. Other times, no. When it doesn't blow cold, the compressor isn't engaging. When it does engage, everything works as it should, no abnormal noises from the compressor or anything. If the A/C works when the car starts, it will continue working as long as the car is running.

I'm wondering if the coolant temp sensor could be at the root of the problem? I know part of it's purpose is to prevent A/C at very low temps.

Here's what I'm thinking for diagnostics:

1) Next time it occurs, pull the connector from the coil on the compressor and see if 12v is present there. If that's the case, then the coil has an intermittent short.

2) If #1 reveals nothing, pull the connector from the pressure sensor on the dryer. Bridge those connectors and see if the compressor comes on. If it does, then the pressure sensor is at fault.

Any other suggestions? It's gettin' hot here in Houston - we need A/C...

__________________
W. Brian Fogarty

'02 S55 AMG (W220)
'92 300SE (W140) - sold
'76 450SEL 6.9 Euro #1164
'76 450SEL 6.9 Euro #521

"Bond reflected that good Americans were fine people, and most of them seemed to come from Texas..." Casino Royale, Chapter VII
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page