Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-15-2001, 02:13 PM
Posts: n/a
Unhappy E420 Electrical Problem

I am having a difficult time locating this electrical problem. I have a 1997 E420 and all electrical components such as windows, locks, sunroof, rear defrost, seats, mirrors and trunk release are not fuctioning with the engine running. These items are operable with the ignition turned on position 1, the minute the ignition is on the 2 position or the cranking the enginge the components go dead. If anyone can help or has experienced the same problem please reply.
Reply With Quote
Old 12-16-2001, 09:21 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Replace the ignition switch.
I have replaced more than 50.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
115 electrical problem solved kip Foss Diesel Discussion 9 07-28-2004 11:23 PM
E420 '97 Driver Side AC Problem asyrov Tech Help 2 07-22-2004 05:48 PM
electrical problem solved MS Fowler Diesel Discussion 1 02-11-2004 01:04 PM
Mystery Electrical Problem URGENT mudditt Tech Help 8 02-14-2003 09:33 PM

All times are GMT -4. The time now is 07:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page