Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-17-2001, 10:34 AM
Registered User
 
Join Date: Apr 2001
Location: Indianapolis
Posts: 87
Backlighting for temperature controls

The backlighting for the temperature control buttons and the backlight for the center vent adjuster goes out while driving. The backlights for the row of switches above (headrest release, rear def., hazards...) all stay illuminated, only the temp control buttons go out. I have checked and replaced the fuses under the hood, is there one behind or under the dash???

Oh, BTW this is on an '88 300E.
__________________
Eric
'88 300E
'00 Expedition
'86 Alfa Romeo Spider
'84 Harley Davidson FLH"X"
Special Edition
'70 FJ40 Land Cruiser (basket case)
Reply With Quote
  #2  
Old 12-17-2001, 10:52 AM
Registered Diesel Burner
 
Join Date: Aug 2001
Location: Northern Virginia
Posts: 2,911
Are you saying that they are out at all times, or are they flickering in and out?

Ken300D

'87 300D
Reply With Quote
  #3  
Old 12-17-2001, 11:23 AM
Registered User
 
Join Date: Apr 2001
Location: Indianapolis
Posts: 87
All of the temp. control buttons and the lights on the center vent adjuster are out. They don't flicker. I will be driving down the road and the next time I look at the panel, the backlights are out on the temp. control strip.
__________________
Eric
'88 300E
'00 Expedition
'86 Alfa Romeo Spider
'84 Harley Davidson FLH"X"
Special Edition
'70 FJ40 Land Cruiser (basket case)
Reply With Quote
  #4  
Old 12-17-2001, 11:56 AM
Registered Diesel Burner
 
Join Date: Aug 2001
Location: Northern Virginia
Posts: 2,911
I see. So it is an intermittant problem. In my case, the lights in the climate control stay out all the the time. The reason: all the bulbs are shot.

I had a case where the glove compartment light didn't work. That was a wire loose at the cigar lighter illumination jack. The hot wire (well, hot when the ignition key is on) "leapfrogs" from there to the glove compartment - and had come loose.

Most of my little electrical problems were more easily solved with the use of the electrical troubleshooting manual that comes on the CDROM.

Seems like you might have a loose wire in the console.

Ken300D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket Cruise Up And Running.. wolf_walker Diesel Discussion 52 12-26-2009 04:45 PM
1979 300 cd heat controls Chris p Diesel Discussion 1 03-29-2004 02:09 PM
German Climate Controls! yeldogt Tech Help 4 08-26-2003 02:35 PM
1978 280CE A/C Controls 78280CE Tech Help 0 08-23-2002 01:24 PM
'76 450sl Heater Controls mburman SL Forum 0 02-26-2002 10:17 AM



All times are GMT -4. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page