Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-22-2010, 06:48 PM
Hogweed's Avatar
Watching SB LII every day
 
Join Date: May 2005
Location: in the back of beyond a.k.a. Pa.
Posts: 3,051
replaced battery-now guage cluster is acting out

1990 300sl
replaced the battery and when i started the car the seatbelt light, battery light, low fuel light all blink, and the whole cluster is dead...no tach, no guages, nothing! what the heck happened and how do i fix it??
thanks
gregg

__________________
0o==o0

James 4:8

"...let us put aside the blindness of mind of those who can conceive of nothing higher than what is known through the senses"
-Saint Gregory Palamas, ---Discourse on the Holy Transfiguration of Our Lord God and Savior Jesus Christ


Centrally located in North East Central Pa.
Reply With Quote
  #2  
Old 07-22-2010, 08:27 PM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
Overload Protection Relay,check the fuse(s)

You may still have the 5 or 7 pin version if it's original.(One fuse in the top)
The New 9 pin (Two 10 amp Fuses in the top) fits all models.

Usually in the space in back of the Battery Compartment.

AND,AND start checking for "loose" grounds displaced in the Battery R+R.
Attached Thumbnails
replaced battery-now guage cluster is acting out-screenhunter_01-jul.-22-20.23.gif  
__________________
'84 300SD sold
124.128

Last edited by compress ignite; 07-22-2010 at 08:41 PM.
Reply With Quote
  #3  
Old 07-22-2010, 09:21 PM
Hogweed's Avatar
Watching SB LII every day
 
Join Date: May 2005
Location: in the back of beyond a.k.a. Pa.
Posts: 3,051
that sounded hopeful but the fuse in the relay is ok and the only ground is the negative terminal
__________________
0o==o0

James 4:8

"...let us put aside the blindness of mind of those who can conceive of nothing higher than what is known through the senses"
-Saint Gregory Palamas, ---Discourse on the Holy Transfiguration of Our Lord God and Savior Jesus Christ


Centrally located in North East Central Pa.
Reply With Quote
  #4  
Old 07-22-2010, 10:30 PM
mespe's Avatar
benzbonz
 
Join Date: Feb 2005
Location: Cleveland, Ohio
Posts: 1,848
Check for corrosion on the battery cable when you replaced the battery? I know batteries go bad, but a corroded pos cable will act like a bad battery.
__________________
Closing the store
Benzbonz.biz
on your smart phone or tablet.
Reply With Quote
  #5  
Old 07-22-2010, 10:36 PM
latief's Avatar
1993 300E 2.8- M104
 
Join Date: Aug 2009
Location: Gainesville, FL
Posts: 518
usually, when the cluster dies suddenly, that means that fuse 5 (or 6...can't remember) has burnt out....check your fuses in the fuse box...easy 2 seconds fix !!! i've seen than happen on 2 cars including mine....
__________________
1993 300E, 2.8 M104 .....
Reply With Quote
  #6  
Old 07-22-2010, 11:38 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,733
The early digital clusters are not exactly robust. What you describe is what we commonly call the "death blinks" around the shop. If no problems turn up with the fuses you are likely in for a new cluster. Make sure you are sitting down when you get the quote on a replacement.
__________________

90 300TE 4-M
Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE
104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
Tuned CIS ECU
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #7  
Old 07-23-2010, 10:31 AM
Hogweed's Avatar
Watching SB LII every day
 
Join Date: May 2005
Location: in the back of beyond a.k.a. Pa.
Posts: 3,051
i've read where they can possibly be fixed....any info on that?
thanks
gregg
Quote:
Originally Posted by duxthe1 View Post
The early digital clusters are not exactly robust. What you describe is what we commonly call the "death blinks" around the shop. If no problems turn up with the fuses you are likely in for a new cluster. Make sure you are sitting down when you get the quote on a replacement.
__________________
0o==o0

James 4:8

"...let us put aside the blindness of mind of those who can conceive of nothing higher than what is known through the senses"
-Saint Gregory Palamas, ---Discourse on the Holy Transfiguration of Our Lord God and Savior Jesus Christ


Centrally located in North East Central Pa.
Reply With Quote
  #8  
Old 07-23-2010, 11:54 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
i've got a spare one with 188k on it

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page