Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2010, 12:46 AM
Registered User
 
Join Date: Jul 2010
Posts: 10
ASR/ABS light help!

Hi guys,
This is my first time posting on these forums, but I have been browsing and using these great forums for awhile now.
I was wondering if anyone here could help me out with a few problems I have.
My car is a 1995 Mercedes-Benz S420. I have a ASR and ABS dash warning light. It comes on as soon as the car is started. It never goes off, unless of course when the car is shut off. I do not have Limp Home mode, the car seems to operate fine, aside from no ASR or ABS. Cruise Control works, Speed Sensitive Steering seems to work just fine.

I have pulled some codes and these two codes are the ones that come on that relate to ASR/ABS.

Pin 6: 5 blinks = Right rear axle VSS sensor (L6/4), open circuit (Some other sources say its the Left rear axle VSS, not sure which one it is)
Pin 7: 6 blinks = Starter lock-out/backup lamp switch (S16/1)

Could someone tell me what those mean? Will replacing the Vehicle Speed Sensor fix the issue for the Pin 6 error code or could there be some other problem such as a bad harness?
The starter lock-out/backup lamp switch, is that the Neutral Safety Switch? If so, will replacing it fix it as well?

Additional information, these are the codes that were there but did not come back yet after clearing them:

Pin 7 - EA/CC/ISC control module (N4/1) or safety contact switch (M16/1s1) or Stop Lamp switch or Cruise control switch or Actual value potentiometer or Starter lock-out/back-up lamp switch (S16/3) or Engine speed signal or Vehicle speed signal or Closed throttle position switch or Safety relay in EA/CC/ISC control module (Did not come back)
-Closed throttle position contact switch (S29/3) (Did not come back)


I hope someone could shine some light my direction. Thank you all in advance!

Reply With Quote
  #2  
Old 07-28-2010, 08:11 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Code 5 in the ABS computer, pin #6 is for the RR wheel speed sensor.

Code 6 in the EA/CC/ISC computer, pin #7 is for the safety neutral switch on the trans.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 07-28-2010, 09:42 AM
Registered User
 
Join Date: Jul 2010
Posts: 10
Thank you. I'll work on getting those parts replaced and go from there.
Reply With Quote
  #4  
Old 07-28-2010, 09:59 AM
Registered User
 
Join Date: Jul 2010
Posts: 10
Where can I find a replacement Right Rear wheel sensor? I can't seem to find any online source that sells it. They only carry the front abs wheel sensors...
Reply With Quote
  #5  
Old 08-07-2010, 07:58 PM
Registered User
 
Join Date: Jul 2010
Posts: 10
I have replaced the Neutral Safety Switch today.

Code 6 in Pin #7 is no longer present. However, the ASR light on the dashboard still illuminates.

Could it be because of the ABS malfunction that ASR light will illuminate as well? (The ABS problem is a wheel sensor issue and ASR probably uses that wheel sensor as well)
Reply With Quote
  #6  
Old 08-08-2010, 05:47 AM
johnflight1's Avatar
Registered User
 
Join Date: Aug 2002
Location: Las Vegas Nevada
Posts: 260
Check that all 4 tires are same size and properly inflated prior to replacing the sensor. I had the same thing happen on my 96 SL500....John.....
__________________
88 W124 3.0
96 R129 119eng
06 ML350
98 ML320 sold
02 CLK55 amg
Reply With Quote
  #7  
Old 08-08-2010, 06:17 AM
Registered User
 
Join Date: Jul 2010
Posts: 10
I got the rear wheel off to replace the sensor only to discover that I do not have rear left or right wheel speed sensors. The mounting location does not have a hole for the screw hole. Confused I contacted a Justanswer Mercedes tech who informed me that my car does not have those sensors but rather, just a speed sensor on the differential.

Now I'm confused because I thought the models with both ABS and ASR have left and right rear sensors. Mine are absent however.

The next question is then what does the error code mean? The 5 LED blinks in socket 6 corresponded to rear right sensor, according to the DTC manuals.

The sensors are absent on both my rear wheel hubs, no signs of them anywhere, yet I only get one error for the right rear.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page