Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-18-2001, 07:38 PM
Registered User
 
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
More problems - 420SEL

I posted yesterday with an odd problem, my 1986 420SEL would stall when shifted from reverse to drive. It was suggested to me that I check and replace the overvoltage relay. I am taking the car into the shop Thursday and will have this checked.

Today my wife reports that turning the key in the ignition would not start the car, but if she gave it a little pedal it started no problem. Any ideas on this one? Is it a related problem, or should I have something else checked out too?

Thanks
__________________
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote
  #2  
Old 12-18-2001, 09:01 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
It sounds like the same problem to me...a lack of idle control.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 12-18-2001, 10:30 PM
Registered User
 
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
Thanks Benzmac, we'll get this checked out.
__________________
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
what problems does the 420SEL have jesseC43 Tech Help 7 05-25-2005 09:26 AM
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 11:25 AM
95s 320 problems are they common?AC/LOCKING system/head gasket leaks joe cantalino Tech Help 0 05-14-2003 11:00 PM
Timing Chain takes out another 420SEL RobertG Tech Help 15 01-09-2003 03:24 PM
420sel problems Benzman500 Tech Help 9 08-22-2000 05:38 PM



All times are GMT -4. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page