Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-06-2010, 11:14 AM
Registered User
 
Join Date: Jun 2008
Location: New Jersey, USA
Posts: 47
1986 300SDL: Cimate Control Unit

Hey guys. My climate control unit used to work fine. Push a button, it worked. Nowadays nothing happens until it seems to warm up. I already replaced fuses and I don't believe it's the blower motor (replaced last year). The recirculator button's light doesn't light when any of the control unit's buttons are engaged. Once the unit warms up and the blower kicks on does the recirculator light come on. Hence I believe it's the control unit itself that's faulty. The defrost button doesn't even do anything. I've already taken the unit out and resoldered the connections on the main board but that didn't change things. No visible burnt marks anywhere on the main circuit board. BTW, when it does finally kick on if I have hit any buttons before it kicked on the ccu appears to remember what buttons I hit and goes thru them all before stopping at the last button press. (if that doesn't confuse you ) Any help would be really appreciated.
--
Tony
__________________
Tony
(Actually, a member since 2000)

Last edited by TonySz; 10-06-2010 at 04:38 PM.
Reply With Quote
  #2  
Old 10-06-2010, 07:37 PM
Registered User
 
Join Date: Jun 2008
Location: New Jersey, USA
Posts: 47
Two, possibly three, capacitors on the CCU circuit board were leaking. I desoldered them, cleaned the board with iso alcohol and put new caps in. I've got to wait for some epoxy on a broken plastic part to dry, then she's going back in for testing.
__________________
Tony
(Actually, a member since 2000)
Reply With Quote
  #3  
Old 10-07-2010, 02:49 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,085
Thumbs up

Look around for a good reman, Programma or Beckmann Technologies does this for those units. I have seen them pop up in junkyards often (two of mine came from there for a real expensive $10 each)

You need an '86-91. '85 and older will not work.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page