Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-02-2002, 11:16 PM
Join Date: Jun 1999
Location: Melbourne , Australia
Posts: 33
190E 2.3 Idle Control Valve

My 1987 190E 2.3 will only idle if I disconnect the power to the idle control valve (otherwise I have to keep the accelerator pressed or the engine will stall).

With the idle valve disconnected the engine idles at 900 RPM when cold but gets upto around 1400 rpm when warm (Limp home mode I assume ?).

I have monitored the current to the valve and have found the following ;

- 570ma when the engine is running at above 1,000 rpm.
- if I take my foot off the accelerator , the current then increases rapidly to around 900ma as the rpm's drop until the engine stalls.

It appears as if this current increase is not enough to keep the engine running as it always stalls when I take my foot off the accelerator.

The idle control valve appears to be operating corectly as when I connected it up to a 1 amp power source the valve opened almost fully.

The likely culprit of the OVP checks out o.k.

Do you think the idle control valve is faulty or could it be the sensors that feed into the KE-Jetronic computer that are playing up ?

Doug McCutchan
Reply With Quote
Old 01-03-2002, 12:24 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
There are four sensors that are involved so that the engine will have a correct idle. These sensors are throttle switch(on butterfly), decel switch (on linkage), throttle position sensor (on air flow housing), & speed sensor on speedo. ALL must function correctly so that the engine will idle correctly!!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 01-03-2002, 08:45 PM
Join Date: Jun 1999
Location: Melbourne , Australia
Posts: 33
thanks, I'll check them all out.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 190E 2.3 8 Valve Slight Rough Idle mctwin2kman Tech Help 5 02-01-2005 08:36 AM
1986 190E 2.3 8 Valve Idle Air Control Valve mctwin2kman Tech Help 1 07-12-2004 02:34 PM
560sl / Idle control valve or amp? msar Tech Help 4 03-07-2004 11:05 PM
No current at Idle valve or EHA valve 1993 190E 2.6L Meza Tech Help 1 02-23-2003 12:40 PM
Benzmac, Steve, someone, please share how an idle control valve fails. Tinker Tech Help 37 07-15-2002 01:01 PM

All times are GMT -4. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page