Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-03-2002, 01:20 PM
Posts: n/a
timing chain and cam failure on 92 500sl

hi, on startup i heard snapping sound car was warm, it broke the outer left cam and the chain, has anyone heard of this problem at 90K miles ? Is this a Mecedes issue ? Boderline suicidal over it, Thanks, Sven.
Reply With Quote
Old 01-03-2002, 02:38 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Unfortunately, I have seen this. The older these engines get, the more I see in this condition. The rails become brittle after ageing. The only fix is to replace the rails and chain at 90k mile intervals and NEVER miss an oil change.

Mercedes V-8's are known for this in the 80's and now here come the 90's engines.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Have you had a timing chain break!? Southern_Son Tech Help 113 06-25-2009 01:59 PM
OM603 timing chain installation report gsxr Diesel Discussion 3 08-15-2003 11:00 AM
560 SEL Rocker Arm Removal hbofinger Tech Help 10 07-23-2003 02:28 PM
500sl broken cam and timing chain svenmd80@yahoo. SL Forum 1 01-04-2002 07:54 AM

All times are GMT -4. The time now is 12:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page