Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2010, 03:42 PM
Registered User
 
Join Date: May 2001
Location: Indiana
Posts: 206
Heated Seat: Relay or Switch?

The heated seat button works in an unusual way on my 02 W210. When I push the top 1/2 of the button nothing happens, no lights or heat. If I push the bottom 1/2 the seat turns on as expected in High, push the bottom again and it goes to the low setting, push it a third time and it goes off. The top 1/2 of the switch doesn't seem to do anything. Would this problem be related to the switch itself or a relay? Or something entirely different?

__________________
1986 190E 186K (For Sale)
(Maroon, Tan leather)
1996 C280 Sport 208K
(Brilliant Silver, Black Leather)
2002 CLK430 Sport 45K
(Brilliant Silver, Gray Leather , Birdseye Maple)
Reply With Quote
  #2  
Old 12-21-2010, 05:05 PM
davidmash's Avatar
Supercalifragilisticexpia
 
Join Date: Mar 2002
Location: Arlington, TX
Posts: 26,633
Can you switch the repays? On my 190, they are under the passenger floor board. In mine, they both turn on high and then time down to low. I cannot turn them on low to start with. I tried swapping the relays but the same happens on both. I have not tried a new switch as it seems weird that it would happen to both at the same time.

I'll follow this thread. May be I can learn what is screwed up with mine.
__________________
Sent from an agnostic abacus

2014 C250 21,XXX my new DD ** 2013 GLK 350 18,000 Wife's new DD**

- With out god, life is everything.
- God is an ever receding pocket of scientific ignorance that's getting smaller and smaller as time moves on..." Neil DeGrasse Tyson
- You can pray for me, I'll think for you.
- When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.
Reply With Quote
  #3  
Old 12-22-2010, 10:27 AM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,833
Probably a fried relay. If it's like my car, the controller with four relays is located under the driver's side rear seat cushion. Open up the controller and you're likely to find that some of the relays are fried. I replaced the relays for around $7 each.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page