Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-2010, 09:37 AM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,341
Trans Vacuum Modulator replace / fluid question...

Going to replace the trans vacuum modulator since they are prone to failure and I have no control over my shift harshness. I assume failure of the part. If not, I have a spare.

Anyway, I read many, many threads on it. I only found one comment saying there is a "little" fluid loss. I want to be sure thats the case. So when replacing, how much fluid can one expect to come out? It may be relative to how full the trans is. But I need to know if I need to pick up some trans fluid before doing this.

__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #2  
Old 12-22-2010, 02:32 PM
Registered User
 
Join Date: Oct 2007
Location: Greater Metropolitan Beaverdam VA
Posts: 2,781
Fluid loss

I think that was my post you are referring to. Fluid loss was a very small, say 3 to 5cc.

Check your vacuum hose to the modulator first. If it is off or rotted, replace it and that may fix your problem. Test your modulator by applying vacuum to it. If it holds vacuum, it is good. If it does not, replace it. There is a plastic pin that is inside the place where the modulator enters the tranny. That pin is somewhat delicate so have a new one on hand in case you mess the old one up. All this stuff is really inexpensive. I don't recall exactly but modulator and pin for $35 rings a bell.
Reply With Quote
  #3  
Old 12-22-2010, 03:54 PM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,341
It arrived this morning! The vac line is pretty new. Plastic is milky white, not yellow at all.

There is a very good change the modulator and line were replaced and that I have a vacuum leak elsewhere causing this issue. But I would rather know for sure the modulator is new to rule it out 100%.

The MB modulator I got I think has the plastic pin you speak of. About 2.5" long, black.

__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page