Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2002, 02:18 PM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Help ASR light 93 500SEL

Guys my ASR light has started coming on when I start the car and it stays on, thus the car is in a crippled mode. What could be causing it. I did a search in the archives I didn't find anything.


Please Help Car is stranded at Home, better than at work I guess.



1993 500SEL 115,000 miles


Cardude
Reply With Quote
  #2  
Old 01-08-2002, 08:47 PM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
Not quite sure what you mean by "crippled mode" but assume you might be talking about "limp home mode" in which the throttle still works but it takes a lot of accelerator travel before engine speed starts to increase. If this is the case, it's probably a bad throttle actuator. Do a search on it.
__________________
Steve
'93 400E
Reply With Quote
  #3  
Old 01-09-2002, 06:55 AM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Thanks, for the reply I will do a search on it.



Cardude
Reply With Quote
  #4  
Old 01-09-2002, 09:03 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
IF only the ASR lamp is on then have the EA/ISC computer scanned for faults! This computer controls the throttle actuator.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 01-09-2002, 08:39 PM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
MB DOC,
I thought that ASR light on + "limp home mode" = bad throttle actuator?

True?
__________________
Steve
'93 400E
Reply With Quote
  #6  
Old 01-10-2002, 06:44 AM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Guys, it just started working properly last night now it functions normally. I'm really worried now.



Cardude
Reply With Quote
  #7  
Old 01-10-2002, 09:02 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
ASR & limp mode can mean a bad "throttle actuator" however ther are about 15 other items that can cause the same thing. If the charging system OVER charges you can get the same results!!
THAT is why reading the computer codes will help with diagnosis.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #8  
Old 01-10-2002, 08:37 PM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
Very interesting! Mine has intermittently gone out while using the cruise control and I had always assumed the worst (i.e., need a new TA at $900) -- sounds like a bit of troubleshooting is in order . . .
__________________
Steve
'93 400E
Reply With Quote
  #9  
Old 01-24-2002, 05:20 PM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Crap the problem is back again



Cardude
Reply With Quote
  #10  
Old 01-26-2002, 07:21 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
ASR and limp mode cause

It may well be the wiring inside the black plastic wiring harness tube that goes to the electronic throttle. Slit it open carefully and check the condition of the wiring insulation. These things have wires that have 'biodegradable' insulation meaning it crumbles off after a few years most often in your car!!
Reply With Quote
  #11  
Old 01-26-2002, 07:30 PM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Thanks I will take a look Sunday,



Cardude
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASR light on when cold vidkid1957 SL Forum 35 06-29-2004 03:13 AM
1990 500SL has ASR light coming on intermittantly allanb888 SL Forum 1 06-17-2003 07:22 PM
(ASR) Acceleration Slip Regulation Light on Moises Piedra Tech Help 3 11-20-2002 07:28 PM
W 140 Speaker in the doors. & ASR Light Poorboy2 Tech Help 1 09-09-2002 09:03 PM
ASR light comes on...loss of power arif Tech Help 4 04-23-2002 01:21 AM



All times are GMT -4. The time now is 05:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page