Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2011, 09:20 PM
Registered User
 
Join Date: Jan 2011
Location: south jersey
Posts: 1
1985 300d odometer error

long time listener, first time caller...
the odometer on my 300d turns miles at the same pace that the trip odometer does. registering 1 mile for every tenth. after about 50 miles it registers normally. the speedo and the trip odometer both work correctly and show correct speed etc. any ideas? common problem? thanks, mdh
Reply With Quote
  #2  
Old 01-25-2011, 11:33 PM
tbomachines's Avatar
ಠ_ಠ
 
Join Date: Mar 2009
Location: Philadelphia
Posts: 4,642
Sounds like a gear may have slipped. The gears are easily accessible if you take the speedo section out of the instrument cluster. That way you can visually inspect everything and order new gears if necessary.
__________________
TC
Current stable:
- 2004 Mazda RALLYWANKEL
- 2007 Saturn sky redline
- 2004 Explorer...under surgery.

Past: 135i, GTI, 300E, 300SD, 300SD, Stealth
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page