Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-30-2011, 08:24 PM
Registered User
 
Join Date: Feb 2010
Location: nc
Posts: 4
1985 190E loud squealing sound and smoke from my belt

I just had the belt tensioner replaced a few weeks ago. The belt is tight.
when i turn the car on i get a loud squealing sound and smoke from my belt.
It started this morning out of nowhere as i was pulling into a parking lot. i havent moved the car since. Any ideas what could be the problems, and any solutions?
Thanks.

Reply With Quote
  #2  
Old 01-30-2011, 08:51 PM
Rebe
Guest
 
Posts: n/a
It sounds like a tensioner may have frozen up on you. It could be the air pump locked up too. You will have to check the different things the belt drives to try and find the problem & maybe loosen the belt some in order to do it.
Reply With Quote
  #3  
Old 01-30-2011, 11:17 PM
Registered User
 
Join Date: Feb 2010
Location: nc
Posts: 4
thanks, i'll go check it out right now.
Not to sure about where to find the air pump.
Reply With Quote
  #4  
Old 01-31-2011, 07:46 AM
Rebe
Guest
 
Posts: n/a
If you have the 2.6L you may have to remove the fan clutch up front to be able to see what the problem is. It's pretty well covered up on that model. Since it happened so soon after replacing the tensioner, it can possibly be the suspect here.
Reply With Quote
  #5  
Old 01-31-2011, 10:02 AM
Cal Learner's Avatar
Registered User
 
Join Date: Aug 2006
Location: Marysville, CA
Posts: 781
No air pump in 1985.
__________________
1988 California version 260E (W124)
Anthracite Grey/Palomino
Owned since new and still going strong and smooth
MBCA member

Past Mercedes-Benz:
1986 190E Baby Benz
1967 230 Inherited from mom when she downsized
1959 220S Introduced me to the joys of keepin' 'em goin'

There are only 10 kinds of people in the world--those who understand binary and those who don't
Reply With Quote
  #6  
Old 01-31-2011, 10:07 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,630
hmmm... could your alternator pulley old and maybe starting to lock up...\

or another pulley where the bearings are going

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page