Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2011, 03:39 AM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
Steering problem 2000 C240

My dads W203 C240 recently developed strange steering problem: When he backs out his driveway and the steering wheel is set all the way to the right and he wants to move back it feels as if the power support is aall gone. You need quite some force to move the wheel back. Suddenly it works normal again. No problems when driving.
Any suggestions where to start looking are appreciated!!!!

Thank you

Reinhard

__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #2  
Old 02-07-2011, 09:13 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like the proportioning valve is sticking inside of the rack.
I would try a fluid & reservoir change first.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 02-07-2011, 02:08 PM
Registered User
 
Join Date: Sep 2004
Location: Seattle
Posts: 1,934
And that is special synthetic fluid in there. At least on my '98 it is. From Fuchs or Febi or the dealer. Check your manual. It is not too expensive though. Maybe 11.00 for a liter. More at the dealer probably.
__________________
1998 C230 330,000 miles (currently dead of second failed EIS, yours will fail too, turning you into the dealer's personal human cash machine)
1988 F150 144,000 miles (leaks all the colors of the rainbow)
Previous stars: 1981 Brava 210,000 miles, 1978 128 150,000 miles, 1977 B200 Van 175,000 miles, 1972 Vega (great, if rusty, car), 1972 Celica, 1986.5 Supra
Reply With Quote
  #4  
Old 02-08-2011, 07:15 AM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
Thanks for your advise. I will try fluid change asap and report back. Talked to a co that remanufatures steering racks. They also advise to check for leaks but believe nothing wrong with steering rack since problem only intermediate.
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #5  
Old 04-12-2011, 03:01 PM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
Problem solved: Dealer replaced steering rack (he offered a used rack) and steering pump. Dad is back safe on the road.
thanks for all your help!

Reinhard

__________________
E 240 2000
E 320 Coupe
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page