Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-19-2002, 02:48 PM
Posts: n/a
300E 2.8L wire harness flame out - Help

My story begins last Monday. I was driving to work in my 1993 300E 2.8L and my car stalled out. I then made it to my local shop. We found that 2 cyclinders were not firing. My mechanic found that one of the three coils burnt up. Further discovery found the dreaded bad wire harness that these cars have. My mechanic changed the engine wire harness and the bad coil but the two pistons still will not fire. Could the CPU board be bad from the wire short?On Monday he will see if the signal to fire the piston comes out of the CPU. Help !! Any suggestions?
Should I sell the car now? 153K miles.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for KeBowers! W140 Wire Harness info... pcmaher Tech Help 7 02-26-2005 06:35 PM
$513 Wire Harness? $700 Idle Control Box? Whoa, Nelly! Ryan M. Tech Help 37 08-24-2004 04:19 PM
94 c class wire harness replacement msethk Tech Help 8 02-25-2004 04:36 PM
Help! Problem after changing wire harness LuckyE320Wagon Tech Help 1 09-15-2003 05:16 PM
R129 Wire Harness Replacement - Labor Estimate? jgl1 Tech Help 3 06-10-2002 11:53 PM

All times are GMT -4. The time now is 12:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page