Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-11-2011, 01:27 AM
zibsBenz
 
Join Date: Aug 2006
Location: Brantford On,Canada
Posts: 46
94 s320 OD trans problem

"OD" seems to be acting up. Car drives along in "OD" ok for about 100Km then every few times it shifts in and out of "OD" quickly.
Will do this 3-4 times within 20 sec. then be OK for about 5mins and starts shift in and out of "OD" again. Does this at speeds over 100km/hr.
Have not notice it at lower speeds.
Pull over shut the car off for a few minutes and it may not do this again for 100km or so. There are times it does not do this for 500Km.
I have noticed the trans will not shift into "OD" unless the shift lever in "D" is pushed over to the far left.
It seems to me it used to be you just put it into "D" and it did the rest automatically. All other gears work ok no hesitation, smooth shifts.
Ideas as to the problem ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page