Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-20-2002, 12:07 PM
Posts: n/a
Fuse problem

My 8 fuse keeps blowing- the one for the blower motor,etc. (Only when I drive it)
Reply With Quote
Old 01-20-2002, 12:26 PM
Registered User
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
Welcome to the list!

It'd help to have a little info about the vehicle: which model, year, mileage . . .

My very limited knowledge in this area is that there are some models with known problems with increasing current draw (and thus blown fuses) in blower motors as they age. I believe there is a factory-approved fix which entails increasing the fuse size -- but please do a search on this before you just put in a bigger fuse.
'93 400E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower Fuse Bypass Texas560sel Tech Help 2 06-23-2003 02:46 PM
Fuse for a/c compressor and blower motor keeps overheating The Warden Diesel Discussion 2 06-16-2003 10:44 PM
S500 intermittent problem Edamartin Tech Help 4 06-10-2003 10:49 AM
Fuse Problem on 500SEL 1985 downsmith Tech Help 2 06-29-2002 05:58 PM
Anti-theft problem RKBurnette Car Audio and Multimedia 6 05-18-2002 02:28 PM

All times are GMT -4. The time now is 07:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page