Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2011, 11:30 PM
Registered User
 
Join Date: Feb 2008
Posts: 223
1987 560SL..... No power, boogs down.....

Trying to post here just because of the massive number on readers as opposed to the SL forum. I took this car into a local transmission shop that is very well-known to have it resealed. When I took the car in everything was fine. Now they have called me and tell me the car runs very bad. I got the car back from them, no charge as of yet. The car feels like a car with a stopped up exhaust, when you give it gas it tries to rev up but then starts to stumble and begins to run very rough. When you put the car in gear and give it gas, you can almost put it to the floor and the car just barely tries to pull off, suddenly it will catch and pick up speed for a few seconds before it starts to stumble again. I have dropped the exhaust thinking it could be stopped up, that didn't help, I have swapped the computers in the passenger footwell, that didn't help either. I pulled both valve covers to make sure it was in time and it was. I replaced both fuel pumps with new units and still no help to my problem. Does anyone have any idea what could be causing this problem. Just idling the car idles perfect, no missing or anything, that is why it really suprises me that when you rev it up it just starts to choke out. Is there anyway that they could have put the transmission back in the car wrong causing something like this? It just seems weird that it was fine prior to this work and after the trans work it is having this issue.

Reply With Quote
  #2  
Old 07-01-2011, 08:10 AM
Senior Member
 
Join Date: Nov 2002
Posts: 736
did they pull the flywheel off, perhaps too change the rear engine seal? it's normal to do that when the trans is out. what could happen is the flywheel can be disassembled, then reassembled wrong. don't know if it will run as i think it wouldn't start that way. btw, the flywheel can come off in 1 piece, also. i just know people who, for some reason, take it apart and had problems with the car . good luck, chuck.
Reply With Quote
  #3  
Old 07-01-2011, 02:45 PM
Registered User
 
Join Date: Jun 2011
Posts: 7
1987 sl

did they rehook the vacuum line to the tranny?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page