Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2011, 12:29 PM
Registered User
 
Join Date: Feb 2001
Posts: 171
95 e320/ w124 Radio/ central lock not working..

Hi all,

Anyone know why sometimes the sound won't come out of radio, the antenna won't engage, the interior light flashes like crazy, and the central lock won't work?

This typically happens when i turn on the radio while the a/c is on, or any combinations ending with turning the radio while the car's running.

I re-seated fuse#C and everything is now back to normal. Hopefully it won't happen again.

Any ideas why it happened? Is it possible that the wiring harness inside the engine compartment is to blame?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page