Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-2011, 10:36 AM
glenmore's Avatar
Registered User
 
Join Date: Sep 2002
Location: Los Angeles
Posts: 963
1991 300CE W124 Engine Mounts...again

Had a hard idle, shaking the car from steering wheel to tailpipe while at a stop and in gear. A bit smoother in neutral but still a little rough. I was suspecting a vaccum problem and was dreading the thought of tearing into those air hoses under the fuel distributor. I have a similar, but not as severe problem with my 2000 C280 so I guess I know what the problem is now.

I had changed the mounts once before at 135m, 12/2005. The old mounts were original to the car and lasted 14 years! The mounts I put in were ebay specials. Serves me right. The new ones I just put in appear to be quality German parts by Rein and were only a little bit more.

The right mount appears to have burst and the rubber was only about a third of the height of a new mount. The underside of the heat shield was coated with fine rubber particles. The left mount was about 1/2 height and had severe splits in the rubber.

The repair is relatively routine, the only difficult part is the top bolt for the left mount. Use a long 1/4" extension threaded from the top, just behind the EHA and a 17mm flex socket. It helps to have someone above holding the extension while you connect it to the socket you have on the bolt. It is pretty much a straight shot when you have the extension in the right hole.

My car with new motor mounts = wonderful again!

glenmore
1991 300CE
1999 C280
2000 C280
2000 C230K

Reply With Quote
  #2  
Old 07-07-2011, 01:58 PM
Registered User
 
Join Date: Aug 2001
Location: Virginia
Posts: 19
I did the mounts on my 1990 300CE many years ago.
As I remember it was a pretty straightforward job.
I used MB mounts and the new ones were about 10mm thicker than the ones that I removed - due to colloapsing / aging.
I guess with aftermarket parts sometimes you get what you pay for !

__________________
1990 300CE-24 (Gone but not forgotten)
2002 SLK 32 AMG
2002 ML320 (Gone)
1995 E320 Cabriolet
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page