Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2002, 12:07 PM
!*mr.bones!*
Guest
 
Posts: n/a
190E A/C Broke, belt squeals then stops!

I did an exhaustive search and could find this exact problem in the forum (at least searching for 190e stuff). I have a 92 190E 2.6 and the A/C just stopped working, and just blows hot air.

When the car is started, immediately there is a belt squeal, a drop in RPM, then the engine goes back to idle. I tightened the v-belt and now, instead of a drop in RPM, the engine will stall without extra gas when started. The A/C still does nothing. Any ideas?

Thanks,
Reply With Quote
  #2  
Old 02-02-2002, 03:32 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Your AC compressor is siezed. If there is a separate belt, just remove it until you have a chance to get the compressor replaced. If not, you will have to get the clutch freed up so that it can allow the engine to rotate, at least, if not get the compressor replaced.

Most if the cars with a single serpentine belt have a speed sensor in the compressor that shuts it off if it slows down too much. This works unless the clutch is also locked up, which sometimes happens.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
  #3  
Old 02-02-2002, 06:52 PM
!*mr.bones!*
Guest
 
Posts: n/a
That's kind of what I figured. What causes this anyway? I've only had the car 2 weeks!

Thanks,
Reply With Quote
  #4  
Old 02-02-2002, 08:42 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Old age, running with low freon and no oil, bad luck. Basically the lubrication failed, and since the compressor is mostly aluminum, the galls and locks up.

Some rebuilt compressors are dirty from the factory, and trash very quickly.

Leaks can do you in too -- 134a in the presence of water and heat decomposes into hydrofluoric aicd!

The clutch can also go bad, as in your case, since with the climate control on economy the compressor should be off, but doesn't release.

Ten years old, lots of miles, not too much of a shock. Big pain, though.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessory belt too tight? Damage A/C compressor? bills Tech Help 0 03-03-2004 11:03 PM
A/C belt Steve 300D Diesel Discussion 4 12-05-2003 10:11 PM
190E 2.3-16 parts for sale kiato4 Mercedes Used Parts For Sale & Wanted 2 06-25-2003 08:14 PM
86 190E 2.3 - Tach, clock affected by fastening seat belt DieselGuy Tech Help 5 01-22-2003 02:51 AM
A/C Belt deeph8 Tech Help 1 01-15-2002 12:27 PM



All times are GMT -4. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page