Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-05-2002, 01:52 AM
wilaur
Guest
 
Posts: n/a
rough idle at operating temp.

I would like to request some help with my 1989 560SEL. It has had a rough idle at after it is warmed up since I bought it at 122k. I had the valves, injectors, fuel distrubutor. intake gaskets plugs changed with no improvement. The fuel distributor has been replace as well. I am frustrated with taking to shops and dealers as I have spent easily 10k chasing this issue to no avail.

I would sure appreciate any help. I have a reasonable mechanical background and am not intimidated by working on the car myself.

Also I should mention the smog pump is frozen, and removed at this time. I may replace it but I can't imagine this would be part of the problem.

Any and help appreciated.

Bill
Reply With Quote
  #2  
Old 02-05-2002, 12:30 PM
moedip
Guest
 
Posts: n/a
Hi Bill - I have a 88 560sel. Had rough idle ( just slight shake - the odd miss) for two years. I finally found it!! Take the injector lines off the fuel distributor and VERY GENTLY remove the fine screens in the fuel distributor that filter dirt from going to each injector. What I used was a thin long screw with a very sharp point and turned it slightly to just grab the screen to be able to pull it out, being careful not to make a big hole in the screen. You could buy new screens - see if Phil has them here - for the price it might make it easier for you. If you see dirt on the screens - you have found the problem. I would clean mine and the car would idle smoothly for about 2 weeks and then start missing again. Problem??? Rusted fuel lines from the tank. The fuel filter is in BACK of the car so it cannot catch the rust as it comes off the inside of the lines. The last stop before injectors is the screen filters in the fuel distributor. When I took my lines out (pain in butt at back by fuel tank) -one broke in two from it's own weight. New lines = no more rough idle. At idle there was enough dirt on the screen to slow the fuel delivery causing the roughness--when you stepped on the gas it worked OK injector cleaners helped very little. Hope this helps you.
Maurice
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough or loping idle under strange conditions odie Diesel Discussion 0 01-20-2005 03:04 PM
Possible HUGE issue: MB dealers issuing potential problem spark plugs, rough idle ericgr SL Forum 1 09-24-2004 08:33 PM
240D "nailing" & rough idle TedG Tech Help 0 07-28-2004 01:44 PM
M103 hard start, rough idle, hesitation SOLVED tryan Tech Help 9 02-12-2003 06:00 PM
Rough smooth intermittent idle keithed Tech Help 7 12-07-2002 01:31 PM



All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page