Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-19-2012, 04:38 PM
Registered User
 
Join Date: Dec 2009
Location: Charlotte, NC
Posts: 44
94 E320 - Intermitten delay wipers

The delay wiper works intermittenly -some days it works and some days it does not work - on my 94 E320 (180k). The wiring harness and OVP were replaced at 165k. The normal and high speed settings work. I have since moved to NC and it rains here quite often.

How do I go about diagnosing this problem? I thought to check the fuse/relay, but I am not sure which one as there seem to be more than one labeled as misc, etc.


Jim

Reply With Quote
  #2  
Old 02-19-2012, 06:01 PM
Registered User
 
Join Date: Jul 2006
Location: Pittsburgh
Posts: 119
On the 96 C280, we had an intermittent wiper and turn signal problem. First thought was the combination switch, but that was fairly new. I searched this forum and found test procedures that focus on the relay, which IIRC, controls the hazard flasher and rear defroster as well. The tests helped me focus in on the relay, which was the problem.

Some people call this the "combination" relay, others call it "wiper", and it may have other names as well. I got a good price on mine from our sponsor here. Fastlane calls it the "Multifunction" relay (navigate Body Electrical-Relay-Multifunction for your car). I hope this turns out to be your problem, because it is the easiest, cheapest thing to repair.
__________________
1996 C280 289K Traded
1997 E420 167K Traded
2001 S430 240K Traded
2010 E550 4matic 80K
2000 GMC Jimmy 198K Gone to Boneyard
2003 Camry LE 196K
2011 Mazda3 i Sport 31K
Reply With Quote
  #3  
Old 02-21-2012, 04:58 PM
95 E320 w124 Wagon
 
Join Date: Mar 2010
Location: Minnesota
Posts: 63
If/Before you buy a new combination relay. I had success repairing it. If you careful, you can actually pop the black cover off. With mine, you could actually clearly see 2 of the soldier joints cracked (my symptoms were hazzard and turn signals worked only 20% of the time). I just re-heated the two cracked solider joints and presto...has held up for the last two years. Saved time and money. For the life of me some took really good photos of the job...but I can't locate it for you. Good luck
Reply With Quote
  #4  
Old 02-21-2012, 05:05 PM
95 E320 w124 Wagon
 
Join Date: Mar 2010
Location: Minnesota
Posts: 63
Here you go...

Here's the info from a member across the pond ...hope this helps:

You’re the 3rd person to confirm that it is that particular joint that is broken, it seems to be the main power supply to the N10 as it knocks out all 3 relays, intermittent wiper, indicators & hazards and rear screen demister.
Thanks for the feed back, always useful to know the cause and the cure of a fault.
Attached Thumbnails
94 E320 - Intermitten delay wipers-n104.jpg  
Reply With Quote
  #5  
Old 02-22-2012, 08:56 AM
Registered User
 
Join Date: Apr 2010
Posts: 9
I have a 97 c230 which had a similar problem. I opened up the combination switch and examined the relay. The contact where it comes together when its energized had broken off.
Reply With Quote
  #6  
Old 02-24-2012, 03:01 PM
Registered User
 
Join Date: Dec 2009
Location: Charlotte, NC
Posts: 44
Thank you all for the suggestions. I will take a look over the weekend. I have a solder gun and would rather try a DIY than spend $60 on the relay.
Reply With Quote
  #7  
Old 08-10-2012, 03:11 PM
Registered User
 
Join Date: Aug 2012
Location: Bristol UK
Posts: 6
Check your ignition switch as I had the wiper, cig lighter, heated seats, and glove compartment light, also the SRS light, would be intermittent and on a hot days they would not come on at all, so I striped the switch down cleaned the contacts closed the contacts together a bit now every thing is working at the moment. Now the SRS light comes on when I go to start the car.1996 E320

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page