Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-18-2012, 08:42 AM
Registered User
 
Join Date: Feb 2012
Posts: 97
W126 380SE cold start takes 5-10 seconds then wont take fuel for 2-3 minutes

I have been bringing my 85 380SE back to life. After being stolen from me, trashed by the thief, then recovered in 2000, the car has mostly been sitting, and I would try to sort out issues when time and money allowed.

The car cranks for 5-10 seconds on cold starts then when it does start, it wont take any throttle or be driveable for 2-3 minutes. Once it has warmed up, it drives more or less normally.

In the process of bringing this car back to life, I have replaced the fuel pump, fuel filter, and fuel distributor. I also removed the fuel tank and did an acetone rinse followed by a power wash at the DIY car wash.

Any thoughts on what might be causing the slow to start and wont take throttle issues?

Brian in Austin

Reply With Quote
  #2  
Old 05-18-2012, 11:22 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Possibly a bad over=voltage relay
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 05-18-2012, 11:40 AM
Registered User
 
Join Date: Feb 2012
Posts: 97
Quote:
Originally Posted by mbdoc View Post
Possibly a bad over=voltage relay
Could you elaborate a bit. What relay? Where located? How can I test it?

I do have an 83 107 380SL that starts and runs well, I can pull and swap parts from it if they are compatible


Last edited by bcolins; 05-18-2012 at 11:51 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page