Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-05-2012, 04:10 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Inside the box: W126 Automatic Climate Control. First Gen.

Hello everyone,

Forum member mccauleybil sent me his climate control unit to see if I could repair it.

He sent:

126 830 02 85 Climate Control Push Button Unit
126.032 - 380SE
126.033 - 380SEL
126.037 - 500SEL
126.043 - 380SEC
126.044 - 500SEC
126.120 - 300SD

000 822 09 03 Temperaturregler.
126.032 - 380SE
126.033 - 380SEL
126.037 - 500SEL
126.043 - 380SEC
126.044 - 500SEC
126.120 - 300SD

I took apart the PBU and discovered that there really isnt much to go wrong inside this unit! There are a few relays, diodes and resistors and thats it!

What I did see that could go bad are a large amount of solder points on the back.

The temp setting wheel also contains some interesting circuitry. There is a small 10k pot mounted at the center of the wheel. There are also three traces that the unit uses as a potentiometer as well. Now from all the other trace style pots that I've seen there has always been a carbon coating present, however this was not the case. I'm not sure if its simply eroded away over the years or simply was never present in the first place... I dont have another PBU to disect for comparison.


PBU Pictures:























__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k

Last edited by JamesDean; 07-05-2012 at 06:37 PM.
Reply With Quote
  #2  
Old 07-05-2012, 04:10 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
PBU Pictures #2
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #3  
Old 07-05-2012, 04:19 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Inside the box: Temperaturregler

As I mentioned before he also sent in this "Temperaturregler" unit.

000 822 09 03
126.032 - 380SE
126.033 - 380SEL
126.037 - 500SEL
126.043 - 380SEC
126.044 - 500SEC
126.120 - 300SD

Its worth pointing out that this unit is not available from most parts houses. I checked with XXXX ordering through the dealership and the "online price" was $522!

I opened the unit up and found that the large axial capacitor was broken loose. Its fairly easy to wiggle around. I checked and its still holding proper capacitance. I'm planning on stripping the coating off this board and re-soldering it. Also you can see several broken copper pieces that go from the board to the pins... I suspect this was causing quite some problems.

The Temperaturregler actually does quite a bit of the leg work for the climate control unit. I suspect that much of this circuitry was integrated into the later 2nd gen units.

From the ETM the following are hooked into the Temperaturregler:
1- Heating Enable
2- Center Flap Control
3- Automatic Slower Speed Control
4- Fresh/Recirculated Air Control
5- Monovalve Heater Water Valve Control
6- Set Temperature Input
7- In-Car Temperature Input

Pictures:







I went through and re-soldered everything, the large capacitor's solder joints were broken on both leads. I repaired the main contact connections, they should do much better now. I think, while its open, the electrolytics should be replaced as well however I don't have any of these sizes in stock so we'll have to see what its owner wants to do..


__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k

Last edited by JamesDean; 07-05-2012 at 06:36 PM.
Reply With Quote
  #4  
Old 07-05-2012, 04:34 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Is this the original style temp control or the version with the mono water valve (second version)?
Reply With Quote
  #5  
Old 07-05-2012, 04:39 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Quote:
Originally Posted by Gilly View Post
Is this the original style temp control or the version with the mono water valve (second version)?
This would be the type with the monovalve.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #6  
Old 07-05-2012, 04:43 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
OK, I didn't think the first gen, original 126 chassis has the monvalve, I thought they has that electric/vacuum servo water valve, what do they call thatthe "Darth Vader" valve? R2D2? Something like that.
Reply With Quote
  #7  
Old 07-05-2012, 04:49 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
OK I found info on the system I was thinking of. The era was the same, but evidently not on 126's. I remember working on them in 116's and 107's I guess. Link to a pdf, really good article on them:
http://www.google.com/url?sa=t&rct=j&q=&esrc=s&frm=1&source=web&cd=10&ved=0CHYQFjAJ&url=http%3A%2F%2Fuserweb.windwireless.net%2F~jimc%2Fchryaccfh%2Facc2servo.pdf&ei=1P31T8iqAcXJqgGh3_iJCQ&usg=AFQjCNHSyqC2PsFu16j_WaBtmUUsHOyvVQ
Reply With Quote
  #8  
Old 07-05-2012, 04:52 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Reason I asked is because if it were the system I was thinking of I didn't see the amp disassembled
Reply With Quote
  #9  
Old 07-05-2012, 06:33 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Quote:
Originally Posted by Gilly View Post
Reason I asked is because if it were the system I was thinking of I didn't see the amp disassembled
Ahh. I've never worked on/encountered the earlier electro/vacuum servo type. All my cars are 82 or newer.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #10  
Old 07-05-2012, 06:43 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Right, and according to the PDF they used this up to 1981, so I was off by a year. I know the 126 was introduced in 1980, so I thought by default the first gen of 126 ACC were this older style. Bear to work on.
Reply With Quote
  #11  
Old 07-05-2012, 06:55 PM
compu_85's Avatar
Cruisin on Electric Ave.
 
Join Date: May 2008
Location: La Conner, WA
Posts: 5,241
W126 production started with the climate system pictured, they were the first to get it. 1985 W124 cars got their climate system first, and it was installed into the W126 for 1986.

The GenII (W124) system does not have the separate "smarts box", everything is done by the bushbutton unit.

-Jason
__________________
1991 350SDL. 230,000 miles (new motor @ 150,000). Blown head gasket

Tesla Model 3. 205,000 miles. Been to 48 states!
Past: A fleet of VW TDIs.... including a V10,a Dieselgate Passat, and 2 ECOdiesels.
2014 Cadillac ELR
2013 Fiat 500E.
Reply With Quote
  #12  
Old 07-10-2012, 07:32 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
Replaced Capacitors in the Temperatureregler!


__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #13  
Old 01-22-2013, 09:11 AM
John Balwit
 
Join Date: Dec 2012
Location: McMinnville
Posts: 10
1982 'W126 with No Heat -- Blower works

Can anyone here point me to a good diagnostic guide for sorting out the climate control system in my 300sd. Suddenly stopped working.
Also, if there was a good article describing the big picture functioning of the system that would help too. If I could find a way to jam the water valve to the on position I could at least use my car while I muster the courage to tear into the system.

Thanks.
John Balwit
Reply With Quote
  #14  
Old 01-22-2013, 09:42 AM
big dog 2's Avatar
ejgolfnten
 
Join Date: Feb 2005
Location: Elk Grove, Ca
Posts: 206
Nice work!

I didn't have the smarts or patience to fix my old one. Got a couple from Pic & Pull instead.
__________________


1989 300E

2005 Acura TL

2011 Hyundai Elantra Limited

Swing hard! Take chances!
Reply With Quote
  #15  
Old 10-31-2018, 12:32 PM
Fold on dotted line
 
Join Date: Aug 2007
Location: SE Mich
Posts: 3,285
Quote:
Originally Posted by balwit View Post
Can anyone here point me to a good diagnostic guide for sorting out the climate control system in my 300sd. Suddenly stopped working.
Also, if there was a good article describing the big picture functioning of the system that would help too. If I could find a way to jam the water valve to the on position I could at least use my car while I muster the courage to tear into the system.

Thanks.
John Balwit

John,
I am looking for the same thing that you are. I'll copy one if I find it first

__________________
Strelnik
Invest in America: Buy a Congressman!

1950 170SD
1951 Citroen 11BN
1953 Citroen 11BNF limo
1953 220a project
1959 180D
1960 190D
1960 Borgward Isabella TS 2dr
1983 240D daily driver
1983 380SL
1990 350SDL daily driver alt
3 x Citroen DS21M, down from 5
3 x Citroen 2CV, down from 6
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page