Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2012, 03:53 PM
SteveH's Avatar
Registered User
 
Join Date: Oct 2012
Location: South Carolina
Posts: 28
Instrument cluster lights question

Hey all;

I pulled the cluster today to figure out why my cluster and console lights don't work. When I pulled the cluster, I made note of which wires/bulbs went in which holes for each dummy light. I noted that the lines are numbered, and were out of order, as follows, on the right side of the cluster, progressing from right to left as you look at the cluster from the driver's seat: line 1 going to the first hole numbered 1; line 4 going to hole 2; blank (i.e. no line going to hole 3, line 5 going to hole 4; line 3 going to hole 5. The sixth hole had the bulb with wires soldered to the other (left) side of the cluster in it.

Is this correct, or should the numbered lines correspond with the number stamped in the metal plate on the cluster?

Thanks in advance!

Reply With Quote
  #2  
Old 11-03-2012, 07:23 PM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,979
Year, make, and model would help members better answer this question.
__________________

1990 190E 2.6L
Reply With Quote
  #3  
Old 11-03-2012, 08:07 PM
SteveH's Avatar
Registered User
 
Join Date: Oct 2012
Location: South Carolina
Posts: 28
sorry about that; forgot I didn't have a sig line with that info!

1990 560 SEL.

Thanks for the reminder!
Reply With Quote
  #4  
Old 11-03-2012, 09:45 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,611
They should go in the numbered order starting with #1 on the outside.
__________________

90 300TE 4-M
Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE
104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
Tuned CIS ECU
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #5  
Old 11-03-2012, 11:24 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Normally the number on the wire is the same as the hole it goes in.
Confused on the soldered wires, you are saying someone extended the length so it would go in to a different hole? Makes me think something was replaced and now the strip doesn't match what was originally there. Put them in order then test the function of each lamp to see if it makes sense.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page