Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2013, 05:56 PM
Registered User
 
Join Date: Jan 2013
Location: SWFL
Posts: 5
420SEL ICV removal:

Hello All, after cleaning the throttle body in my 89 420sel.. it has developed a High idle symptom.. after some research was determined that the ICV should most likely be cleaned.. The two hoses connected to the ICV are very hard and brittle.. so before removing I went ahead and ordered brand new hoses... is there any other procedure I should be aware of in the removal of the ICV other than the connector, 1 screw/clap and connection to the 2 hoses? From other threads I have done some homework on cleaning the ICV, but in case anyone has anything to add It would be much appreciated... Thanks all so much in advance!!

Reply With Quote
  #2  
Old 01-26-2013, 02:09 PM
SpecialDelivery's Avatar
SWFL Benz Clubbin...
 
Join Date: Jun 2011
Location: Cape Coral, FL
Posts: 393
Ok so Reg stopped by today and we looked at the IACV....I did the 9v battery thing, heard a click...we checked resistance of the valve five ohms...we have five volts with the engine running and ZERO instead of 12 with key on ...that made little sense to me but it's what the multimeter said....

From what I've read it could be the control unit...I dont know enough about the gassers to get into it. I told Reg we needed to research and referred him to a great local indie who knows the cars really well.

I was thinking what we should do, as I have done on other cars before...is remove the valve and clean it. The high idle started when we were squirting intake cleaner at the throttle body while running the engine right before an oil change. There has got to be some carbon knocked loose and chunked up on the valve right?

Well without knowing the process for removal and reinstallation of the valve...I didnt want to try. Reg has new "boots" for it...still...I told him we need to research this some more.

If anyone has suggestions on diagnosis and or can point me to the RnR procedure for that valve...much obliged.
__________________
-SpecialDelivery
1985 300CD Silver/Blue H&R Suspension (Sold, still cryin over that)
1982 300SD Silver/Blue '85 OM617 (Sold)
1982 300D - Blue/Blue (Sold)
Reply With Quote
  #3  
Old 01-26-2013, 11:00 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,429
How high is the idle? My 420 likes to idle around 1000-1200 in park, but 600-700 in drive....if I unplug the idle valve it goes much higher (1600-1700 or so)
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 102k - mine - (OC-104,600)
'17 Metris(VITO!) - 26k - wifes (OC-25k)
'09 Sprinter 3500 Winnebago View - 57k (OC - 63k)
'13 ML350 Bluetec - 73k - dad's (OC-75k)
'01 SL500 - 92k(km) - dad's (OC-94,000km)
'16 E400 4matic Sedan - 122k - Brothers (OC-125k)
Reply With Quote
  #4  
Old 01-27-2013, 12:14 PM
Registered User
 
Join Date: Jan 2013
Location: SWFL
Posts: 5
Idle was normal around 650-700rpm... After foaming the throttle body car now idles between 1200-1500rpm in park... Normal idle in drive

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page