Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-2013, 02:28 AM
Registered User
 
Join Date: Apr 2013
Posts: 16
Electrical connector location

New member, quick question. I am replacing the evaporator in my 97 e320 and have done most of the work already. Putting it back together. I can not remember where one electrical connector goes or plugs to.
It is located on the passenger side. It has just two wires, brown and another with stripes white and blue. I think goes to a bulb, but don't remember where it goes.
I still have not put the dashboard back. I see the connector for the glove compartment, the connector for the tweeter and this other one, which I can remember where it goes. Anyone willing to help, appreciated...
Jdemoya.

Reply With Quote
  #2  
Old 04-02-2013, 02:29 AM
Registered User
 
Join Date: Apr 2013
Posts: 16
I meant can't remember where it goes.
Jdemoya
Reply With Quote
  #3  
Old 04-02-2013, 05:01 AM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Post a picture of it.
Reply With Quote
  #4  
Old 04-02-2013, 03:58 PM
Registered User
 
Join Date: Apr 2013
Posts: 16
[IMG]C:\Users\pacosoide\Pictures\Evaporator w210\dscf0037[/IMG] Here is the picture. This is on the passenger side. I hope I can do this right. First time trying to attach a picture.
Thanks for the help,.
Joe.
Reply With Quote
  #5  
Old 04-02-2013, 04:17 PM
Registered User
 
Join Date: Apr 2013
Posts: 16
I think I have this ready for the picture. Here it goes.
thanks, Joe.http://www.peachparts.com/shopforum/attachments/tech-help/110527d1364933819-electrical-connector-location-dscf0037.jpg
Attached Thumbnails
Electrical connector location-dscf0037.jpg  
Reply With Quote
  #6  
Old 04-02-2013, 04:48 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Nope, no good. Push the reply button, then down below the box where you enter your text, you see a yellowish box that says "manage attachments", you click that, then click the "browse" box, that will allow you to find the pic in your computer, then press the download box.
Reply With Quote
  #7  
Old 04-03-2013, 08:33 AM
Registered User
 
Join Date: Apr 2013
Posts: 16
Here is a another picture. It shows the passenger side, the connector.
Thanks for the help.'
Joe.
Attached Thumbnails
Electrical connector location-dscf0034.jpg  
Reply With Quote
  #8  
Old 04-03-2013, 08:39 AM
Registered User
 
Join Date: Apr 2013
Posts: 16
Here is a close up of the connector itself. Hopefully this will help.
Joe.
Attached Thumbnails
Electrical connector location-dscf0037.jpg  
Reply With Quote
  #9  
Old 04-03-2013, 12:40 PM
Registered User
 
Join Date: Nov 2008
Posts: 60
I have '93 300e. It looks exacatly like the one I replaced bulb in yesterday in passenger side vent near airbag.
It must be going to climate control(a/c) vents. Either in middle vents or passenger side vents.
__________________
1) '04 S500 Gold/Beige......120k Miles
2) '93 300E 2.8...Green/Tan MBTex..........202k Miles(and going)
3) '89 420SEL...Light Blue/gray Leather....155k Miles (Retired )
Reply With Quote
  #10  
Old 04-03-2013, 01:58 PM
Registered User
 
Join Date: Apr 2013
Posts: 16
Thanks very much, I found the location on the air vent.
Joe.
Reply With Quote
  #11  
Old 04-03-2013, 08:08 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Glad you found it!
Reply With Quote
  #12  
Old 04-08-2013, 01:11 PM
Registered User
 
Join Date: Apr 2013
Posts: 16
Can you tell me where to find the replacement bulb?
Do you know the ge or Sylvania part number?
Thanks, joe.
Reply With Quote
  #13  
Old 04-08-2013, 08:57 PM
stormyc88's Avatar
muffled but untamed
 
Join Date: Oct 2010
Location: Babylon, NY
Posts: 160
I have a 300E, but that connector looks exactly like the one on my car. Therefore, I would assume they use the same bulb. When I replaced mine, I couldn't find any markings on the old bulbs, so I researched through this forum, and found the replacement bulb is:

Osram/Sylvania 2721 12volt 1.2 watt

Easily obtainable at any Auto Zone
__________________
Streetside: 1987 Mercedes 300E Petrol Blue/Green
2014 Ford Mustang Grabber Blue
1999 Ford Ranger Green

Dockside: 1968 Eltro 17
1985 Silverton 34C
Reply With Quote
  #14  
Old 04-09-2013, 12:14 AM
Registered User
 
Join Date: Apr 2013
Posts: 16
Thanks for the info.
Cheers. Joe.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page