Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-14-2002, 08:33 AM
Posts: n/a
Rear Suspension Problems 300TD

Has anybody replaced the Accumulators on a 300TD (hydropneumatic) suspension? My 79 wagon has a very bouncy ride. I am told it is the accumulators, which I believe are air chambers which keep the struts in balance.

Question: is replacement as easy as it seems? Do these have to be bled or pressurized? Or do I just unhook, unbolt and replace? Am I going to get a face full of hyd. oil?

Any advice will be much appreciated. Thanks.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
86ing the hydraulic rear suspension Benzcrusher Diesel Discussion 20 05-12-2005 11:24 PM
126 rear suspension - done! gidpor Tech Help 8 01-21-2005 10:54 AM
question about 300E rear suspension part WANT '71 280SEL Tech Help 2 06-10-2004 07:43 PM
f/s rear suspension complete w/diff.also rear body clip sscoupes Mercedes Used Parts For Sale & Wanted 5 04-19-2004 10:33 AM
W123 Rear Light Problems rmmagow Tech Help 6 10-13-2002 01:32 PM

All times are GMT -4. The time now is 10:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page