Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-06-2013, 02:27 AM
Registered User
 
Join Date: Apr 2013
Posts: 3
2004 ml 350

Low range light flashes a few times on start and goes away.
Is there something wrong? If so, how do i resolve this.
Bear in mind i have just replaced the crankshaft sensor, is this related in anyway.

Please advise. Thanks much

Reply With Quote
  #2  
Old 05-06-2013, 12:09 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 3,047
The low range motor probably needs to be re-synched. With the engine running shift the transmission into neutral. Push the low range switch. The low range motor will either engage, and the light will stay on, or it won't engage, and the light will start flashing rapidly. You may have to do this two or three times.

If the motor is locked up you may need to help it along with a few taps from your favorite hammer.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page