Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-17-2002, 01:44 AM
oldsouth's Avatar
Registered User
 
Join Date: Feb 2001
Posts: 610
High Altitude Blues

Just got back from a ski trip to Colorado and had some problems with the 1995 S-350 Diesel. I did all the cold weather stuff like fuel antigel and such but the morning after I got there, when I cranked the car up it started running rough at idle and smoking excessively. It would run a little better after it warmed up at highway speeds but as soon as I slowed down and let it idle it would run rough ( like a miss ) and smoke. I added some Power Service octane booster and cleaner and ran it for several tanks but the problem continued until I got back to a lower altitude. I am from Louisiana. My first guess is injectors. Has anybody else had a similiar problem? How do I test the injectors? Car is running great now I am back home but I know something is wrong and don't want it to happen again if I travel to a high altitude place. Car has 173,000 miles and never had an injector off of it.
__________________
1995 S-350
370K + SOLD
1952 220B Cabriolet
39K kilometers + SOLD
1998 E300D
285K +
2006 E320CDI
130K +
Reply With Quote
  #2  
Old 03-19-2002, 12:06 AM
oldsouth's Avatar
Registered User
 
Join Date: Feb 2001
Posts: 610
??
__________________
1995 S-350
370K + SOLD
1952 220B Cabriolet
39K kilometers + SOLD
1998 E300D
285K +
2006 E320CDI
130K +
Reply With Quote
  #3  
Old 03-19-2002, 10:50 AM
moedip
Guest
 
Posts: n/a
Here in Canada I found a truck injector rebuilder that can check car injectors - If I bring them in he charges me $10 CDN for each injector. Check around for an injector rebuilder in Louisiana and have your injectors checked - with that mileage it is almost time - and it might be cheaper than going to a MB dealership. By the sounds of your description - I would suggest the only one or two injectors could be culprit. Have them all checked to be safe. The other faster alternative would be to contact Phil at Fastlane and buy and install new ones. They are not hard to change.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning; High on the dipstick was 3 litres!!! AMG CE 36 Tech Help 2 07-22-2003 05:01 PM
560SL High Idle and Aux Cooling Fan Problems harcar Tech Help 4 05-23-2003 02:41 PM
Sometimes high...sometimes low.. KylePavao Diesel Discussion 5 03-30-2003 06:47 PM
No High Beams rebootit Diesel Discussion 1 03-15-2003 01:48 PM
High Oil Pressure Joseph_H Tech Help 22 03-04-2003 01:07 PM



All times are GMT -4. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page