Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2013, 06:42 PM
Registered User
 
Join Date: Apr 2008
Posts: 125
'85 190E--right turn signal not working

Just the right turn signal is not working...brake lights work fine, so does head lamp. Left turn signal also works fine.

Could this be a bulb?

Also--#13 fuse is blowing. Blows as soon as a fuse is connected. Don't see any mention of right turn light on fuse description though. i did apparantly break the power antenna by forcing it down. Live & learn--could this cause the fuse to blow?

thoughts?

Reply With Quote
  #2  
Old 07-04-2013, 11:30 AM
Registered User
 
Join Date: Jun 2013
Location: PNW
Posts: 242
You can disconnect the power antenna - there is an electrical connector.

For the turn signal problem, you can try swapping bulbs from the left side to the right side. If the right side starts working, then a bulb or bulb connection problem.

Be sure to replace with a Mercedes specification bulb only! (If that is the problem.)

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page