Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2002, 02:24 PM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
Question Stalling 190

Hello all,
It's been a little while. I am asking for some quick help. I am at work now and have some of the tools to fix a possible problem. My wife's 190e has been stalling for about a year now. Only randomly upon decelleration. It would always restart immediately with no problem. Today, I was driving down the road actually accelerating and the thing just quit on me, and it wouldn't restart. I let it set for about 5-8 min and then it finally started for me. I was able to return back to work but now I am affraid to drive it. If that happens at a light, ya look like a real schmuck. Any help would be greatly appreciated.

Kodaik
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
  #2  
Old 03-21-2002, 03:10 PM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
Ok, I just went out and checked the resistance and voltages of the coil and the Ignition Control Unit. ICU seemed pretty good but the coil didn't. The resistance was low and the voltages were off. I know the obvious answer is "that's the problem" but I just want to be sure, I am not in a position to just start swapping parts in and out.

Thanks,

Kodiak
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
  #3  
Old 03-21-2002, 03:51 PM
Registered User
 
Join Date: Apr 2001
Location: Washington, DC
Posts: 223
try replacing/checking the distributor cap and rotor.
__________________
'98 C43 AMG
'88 420SEL
'93 190E Limited Edition (including factory Sportline package)
Reply With Quote
  #4  
Old 08-29-2002, 09:48 AM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
Turned out to be the fuel pump relay.
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'87 300E Stalling Garth Tech Help 21 09-11-2008 10:03 PM
190 Evolution 1 Stalling solved! UKEvo Tech Help 7 01-28-2004 03:43 PM
190 series, W201 sales literature Joseph Bauers Mercedes Used Parts For Sale & Wanted 2 11-20-2002 11:22 PM
190 2.6 for sale hemphog Featured Cars 1 08-12-2002 12:46 PM
Correlation between high engine temps and stalling? screedchan Tech Help 7 08-27-2001 01:24 PM



All times are GMT -4. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page