Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-24-2002, 04:18 PM
Posts: n/a
more OvervoltageProtection Relay questions

1988 300E - warm engine - second or third start works - beside a slightly faster than normal idle (800-900 rpm) - otherwise, runs fine - suspect bad OPR - any positive indicator?? - one archive search post states that a bad OPR is indicated by the ABS light - confirm??? - any other indicator???
Reply With Quote
Old 03-24-2002, 04:21 PM
Posts: n/a
10 amp fuse is O.K.
Reply With Quote
Old 03-24-2002, 06:14 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
ABS light does not always come on... it can, but if it's not on, OVP is still likely suspect.

Also, if the car doesn't start, tap the OVP once or twice and see if it then turns on.
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 03-24-2002, 06:41 PM
Live to Learn
Join Date: Mar 2002
Location: Raleigh NC
Posts: 145
A bad OVP on a 300e normally causes a low idle.
Mercedes Benz Master Tech
ASE Master Technician
Diagnostic Technician
Owner of "Behind the Star Inc."
Raleigh NC.
Reply With Quote
Old 03-25-2002, 09:57 AM
Posts: n/a
Thanks for replies - if not the OPR, any suggestions as to cause of problem - 156,000 mi - perfect condition otherwise - thanks again
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 - 84SD Questions (GP Relay & Flap Actuators) Fisherman Diesel Discussion 5 09-16-2004 01:48 PM
Klima relay solutions for '85 Stage_wizards Tech Help 0 08-08-2003 08:04 PM
1981 300SD glow plug relay, HELP! TheLaw Diesel Discussion 4 09-10-2002 01:10 PM
Klima Relay questions (1986) Amuso Tech Help 2 06-20-2002 02:58 PM
Relay questions crookednose Tech Help 10 09-04-2001 03:13 AM

All times are GMT -4. The time now is 02:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page