Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-16-2014, 10:00 AM
Registered User
 
Join Date: Feb 2014
Posts: 1
Sls problem w123 250 lang.

hi Guys and greetings from the west of Ireland,the rear suspension on my 250 lang 'gas'(petrol in my part of the world) was hard over bumps.I've just replaced the accumulators/spheres but things have not improved.The car previously never sagged and the fluid seems to be returning to the resevoir(pump ok).Tried manually moving the 'fill- empty' lever with the car idling but nothing happens(no movement).Thinking their was an air lock I 'cracked' off the banjo fittings on the struts-air and fluid came out,the rear dropped a bit but has not re-levelled.It seems the valve is not refilling the struts..I'm using citroen type LHM fluid..any help appreciatedBarry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page