Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-03-2002, 11:01 PM
dynalow's Avatar
Registered User
Join Date: Feb 2002
Posts: 1,208
Rough Idle Frustration

Just took my 1988 300CE in for 45,000 (yes) mi service at an MB dealer. Told rep it had a rough idle.....occasional miss.

Later: "Well..these old steel injectors get pitted and there is bad atomizaton.. you need new ones...brass, better atomizaton,life, etc.

But with new plugs,main fuel filter, and new ingition rotor and cap, "it's still not right." So, we took out your fuel regulator (?) and replaced it with one out of a 91/92 190 and guess what, it's running ok. We'll let you have the car for the weekend, but you need a replacement and the price of a rebuilt is 777.00. Call me next week.

So I get it home and it idles rougher now than before when stopped with engine in gear( with engine temp about 80c and air temp about 70f) and also has a split second hesitation when moving off from a cold start.
The symptoms are a quick irregular misses felt right up through the seat. In gear at idle, the engine is turning about 6000-6200 rpm.
So, I'm down 1,300 bucks and heading further south.

Anyone have any thoughts on where else to look (electrics maybe?) I'm afraid they are just replacing parts hoping to find the problem.

Appreciate the feedback...

Reply With Quote
Old 04-04-2002, 09:12 AM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Question I wonder...

if they replaced the fuel pressure regulator OR the fuel distributor. BIG difference in price and part. Check your papers.
'86 300E
Reply With Quote
Old 04-04-2002, 10:11 AM
Registered User
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
that's mickey mouse stuff they did on your car!!
run away as fast as you can while you still have
money on your wallet/bank.

ask and look around for an independent mechanic
in your area. better still, spend time and research
on the problem.
Reply With Quote
Old 07-09-2002, 05:21 PM
Registered User
Join Date: Feb 2001
Posts: 84
Miss problem in 300CE

I have a similar problem with my 1990 300CE. Have changed practically all ignition components, fuel distributor, injectors/seals/
I just replaced my igntion wire set and bought is from, they make good set. Also, cleaned all electrical contacts, replaced all fuses too. I also found that by reducing spark plug gap from 0.030 to 0.025 made the car run much smoother. I do know that 92-95 300CE has faulty engine wiring harness, MB had changed their manufacturer, expensive item.
It seems that this is a common problem in 300CE.
Any one have any success??
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
240D "nailing" & rough idle TedG Tech Help 0 07-28-2004 12:44 PM
my low, rough idle, stall, hot /start solution: E320/300 rvenerac Tech Help 3 11-20-2003 09:59 AM
Idle very rough when cold Hurshi Tech Help 2 02-10-2003 01:21 PM

All times are GMT -4. The time now is 02:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page