Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2014, 10:54 PM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,939
Arrow w201 check engine light code 17

Need help. As the title suggests, I am getting a check engine light code 17 which says "O2 sensor is shorted to positive or ground" I have replaced my O2 sensor, but I am still getting the code. Where does the O2 sensor wiring trace to? Does it go to the OVP? Any advice?
__________________

1990 190E 2.6L
Reply With Quote
  #2  
Old 06-26-2014, 08:50 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,019
On mine it went right up into the CIS-E module. Only the heater lines went to the MAS unit. I don't think the OVP is involved.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #3  
Old 06-26-2014, 03:30 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,026
Probably a wiring issue, have you traced the wiring from the o2 sensor connection back to the ECU and verified there's no short?
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 78k - mine - (OC-80,500)
'17 Metris(VITO!) - 8k - wifes (OC-10k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'89 420SEL 166k - mine (OC-167,000)
'01 E320 - 171k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 49k - dad's (OC-52,000)
'09 E350 4matic Sedan - 129k - Brothers (OC-128,000)
Reply With Quote
  #4  
Old 06-27-2014, 02:48 PM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,939
I traced it yesterday, but didn't see anything out of wack.
__________________

1990 190E 2.6L
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page