Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-13-2002, 10:47 AM
Registered User
 
Join Date: Sep 2001
Location: Austin
Posts: 28
Exhaust Knock

I've got a 97 SL500 with 60k. It makes a knocking sound during deceleration. The car runs fine. Is this a cat problem?

Thanks,
Lyndon Tilson
Reply With Quote
  #2  
Old 04-13-2002, 02:10 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Haven't seen many late model MB cats fail in that way. The BMW V8 has that happen all the time.

My main reason for answering is that you might not know that your catalysts are probably still in emissions warrantee. (8year? 80,000 miles) (not sure about the time but just had one of my 540i cats done a few months ago under warrantee (97 540i 51k miles).
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 04-13-2002, 03:44 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Question Could it be a loose exhaust hanger?

Just a cheap suggestion before the big expense!
__________________
J.H.
'86 300E
Reply With Quote
  #4  
Old 04-13-2002, 05:57 PM
Registered User
 
Join Date: Sep 2001
Location: Austin
Posts: 28
Exhause Knock

Thanks for the hanger suggestion, but unfortunately its definately an internal knock.
Reply With Quote
  #5  
Old 04-13-2002, 06:28 PM
Registered User
 
Join Date: Jul 1999
Location: Youngstown, OH
Posts: 150
lyndongt

I had a bad CAT on a 1998 E320 that was fixed about 6 months ago under the 8/80000 federal emissions warranty after some discussion with the service supervisor who initially said it was not covered; but, we got it all sorted out.

It took me a few service visits to get it identified because it NEVER happened when I left the car. I made arrangements to drive with the service manager. This way I could ensure the problem was occuring.

Mine only did it when the car was VERY warm from driving on the expressway. Even idleing for a mere five minutes gave the CAT enough time to cool down and eliminate the problem. When it was WARM I could just lightly rev the motor and it would rattle every time the motor was idleing down.

Just find a protocal where you can consistently reproduce the problem and meet with service manager. I went as far as to video tape (with sound) how I reproduced the problem so at least the mechanic knew I wasn't imagining this it case it decided not to act up.

Good luck,

Intruder
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Exhaust Clamp W210 DaveJ Tech Help 2 10-02-2003 03:20 PM
Noisy 300E Exhaust Bud Tech Help 5 07-24-2002 10:29 PM
Exhaust system for 107 model kctme SL Forum 5 06-17-2002 12:00 AM
What is the best way to position exhaust system on car? Steve190E 2.3 Tech Help 3 01-23-2002 12:56 PM



All times are GMT -4. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page