Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-08-2014, 01:29 PM
Tbohs
 
Join Date: Aug 2005
Posts: 15
Unhappy Yuck, need help

1995 S420 went to replace the oxygen sensor and found the old unit plug into the main wiring harness had fused from an overheated catalytic converter, preventing old unit from being unplugged from the harness. Any suggestions on how to fix this? Much thanks for any ideas.

Reply With Quote
  #2  
Old 08-09-2014, 08:44 AM
Hirnbeiss's Avatar
ich fahre, also bin ich
 
Join Date: Mar 2002
Location: South Florida
Posts: 1,660
You can check the EPC, or ask dealer, if there is a repair harness. Otherwise, Check on a universal sensor, which I think comes with a connector you splice up to your existing wires.

__________________
Prost!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page