Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2014, 09:50 PM
Registered User
 
Join Date: Jul 2006
Location: east coast Canada
Posts: 121
1996 S420 no start

I picked up this car a few weeks ago as a keeper , it only has 72000 kms on it it ran and started fine although the last 3 weeks it has been started and moved frequently and not really allowed to warm up . so when I went to pick it up it would not start, so today i replaced the plugs NGK still no start there is fuel pressure because when I relieved the shreader valve gas sprayed the windshield. I also put some gas into the intake and the car would run for a few moments then cut out . I believe i have an issue with the injectors and I m just wondering where to go from here or if it is something entirely different ,thanks for any assistance

Reply With Quote
  #2  
Old 08-09-2014, 10:28 PM
jake12tech's Avatar
Registered User
 
Join Date: Nov 2011
Location: Philadelphia, PA
Posts: 2,770
72KMS? That isn't much at 44000 miles. Car has been sitting hasn't it?

More info needed.
Reply With Quote
  #3  
Old 08-09-2014, 10:37 PM
Registered User
 
Join Date: Jul 2006
Location: east coast Canada
Posts: 121
it was sitting for about 5 months that is it but started fine up until I treid it last night and it would not run sounded dry of fuel and when I took off the air breather there was no smell of fuel
Reply With Quote
  #4  
Old 08-10-2014, 08:00 PM
Registered User
 
Join Date: Jul 2006
Location: east coast Canada
Posts: 121
today I replaced the AMM and the car started right up so there you go. Solved
Reply With Quote
  #5  
Old 08-11-2014, 08:01 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,037
What is the AMM?

__________________
Fred Hoelzle
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page