Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-15-2014, 03:01 PM
Registered User
 
Join Date: Sep 2004
Location: Seattle/ Hood River
Posts: 115
280E idle drop when put in drive

I have a 1980 280E, idles smooth, compression below ideal at 140-145psi, starts instintly. I have the idle set to 950rpm, but will drop to ~500rpm when put in drive. I haven't been able to find a vacuum leak, but I assume this must be the problem.
Any other thoughts on the cause?
__________________
80 280TE- 5 spd, 15" BBS, W126 brakes,16mm rear sway etc
83 280TE- 5 spd
85 280TE show quality original
85 280SL- 15" Bundts, 5 spd
05 E320W
56 XK140MC
65 XKE
73 911T
62 Healey Tri-Carb
56 Healey 100M
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page